icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.zmdqzc.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

云鼎彩票 www.025585.com-高频彩追号必死| www.89ek.com-焦点篮球竞彩计划| www.8686.vip-福利彩和体育彩| www.72606.com-彩谜天地联销图今天| www.254414.com-亚博彩票官方网站| www.417733.com-苹果版彩票16| www.529551.com-徐文轩专家彩票网| www.071523.com-惠民彩票计划| www.876625.com-环球迅8彩票| www.984327.com-体彩助手登录不了| www.up4.com-好123彩票走势图| www.xe04.com-福彩三d谜语| www.69083.com-网络彩票稳赢| www.3617.biz-合肥体彩中心在哪| www.17381.com-足彩比分结果查询| www.69213.com-彩票平台输钱怎么办| www.019932.com-镇江体育彩票转让| www.124744.com-迷彩图-| www.312370.com-彩51客户端官方网| www.418005.com-马卡龙简笔画彩色| www.533353.com-更多彩种购彩| www.627263.com-篮彩258网站| www.72kf.com-下载十一选五大彩鲸| www.423166.com-中国体育彩票标志图| www.933914.com-探探彩票托是转职吗| 亿发彩票www.530833.com| www.1973.date-什么是福彩智慧彩站| www.18269.com-五分彩是不是正规的| www.215566.cc-全天彩票实时计划| www.27992.com-彩票168公式| 熊猫彩票www.555xm.cc| www.9743.cn-彩宝网是什么网站| www.59297.com-福彩站怎么赚钱| www.026888.com-彩票跑路-| www.107043.com-竞彩足球官方网站| www.178860.com-安徽时时彩快3投注| www.078068.com-玩彩網-| www.cp5058.com-上海快三开奖一定牛| www.03710.com-人一定要买彩票| www.60192.com-分分彩挂机稳赚| www.079626.com-3d彩票规则玩法| www.187769.com-买彩票必中咒语| www.290190.com-大家赢彩-| www.366838.com-极客彩票主管qq| www.470289.com-买足彩属于赌博吗| www.558905.com-夸男生的彩虹屁| www.635066.cc-做时时彩好挣钱吗| www.776436.com-时时彩票怎么玩才赚| www.867328.com-查中国福利彩票开奖| www.952039.com-彩神可靠吗-| 博友彩www.979683.com| www.yp83.com-奇妙三数字彩票软件| www.51862.cc-3d双彩图谜-| www.8840.me-全国地方彩种| www.43699.cc-183彩票-| www.96096.cc-违反彩票管理条例| www.89md.com-福彩3d太湖谜图版| www.133842.com-淘彩票注册风险| www.513089.com-百度808彩票网| www.110296.com-七星彩单双尾| www.222460.com-免费湖北快三计划| www.331811.com-快三012路技巧| www.445597.com-海南特区彩票论坛网| www.68xq.com-世界有名的博彩公司| www.832.tv-天吉彩票app下载| www.206753.com-彩票大小单双玩法| www.296118.com-湖北快三怎么玩最稳| www.387625.com-七星彩18002期| www.522358.com-腾讯分分彩怎么平投| www.663646.com-go彩票下载安装| www.741717.com-南京彩旗快三走势图| www.807149.com-彩博士全能王破解版| www.913939.cc-3d彩之网相年富| www.07tf.com-体彩6?1开奖| www.797.in-福彩新浪直播| 大众彩票www.998786.com| www.884201.com-体彩七位数走势图| www.25rr.com-华东福彩6-| www.6819.biz-新浪彩票图表频道| www.47728.com-好彩自然来什么意思| www.873329.com-重庆体育彩票幸运| www.431446.com-悉尼快5彩票算法| www.220826.com-彩神app破解| 彩之家www.24czj.com| www.3516.cn-天天爱彩票人工客服| www.474591.com-彩名堂快三聊天室| www.619736.com-新浪彩票任九开奖| www.140854.com-老猫研彩-| www.438427.com-全国最新彩票开奖| www.93hm.com-淘宝购物送彩| www.592653.com-秘梦解图七星彩解码| www.18uf.com-福彩3走势图d跨度| www.191787.com-快三有没有体彩| www.988611.com-必中彩票是个坑| www.281388.com-河内彩开奖号码记录| www.444953.com-义乌体彩投放| www.568613.com-玩什么彩票平台赚钱| www.035673.com-魔方彩票靠谱吗| www.526941.com-体育彩票开桨结果| www.706329.com-老挝博彩打工| www.945500.com-好运快三百度百科| www.239941.com-江苏快三兼职可靠吗| www.611.cm-聚合手游彩票| www.787971.com-特彩吧app下载| www.954045.cc-体彩虚拟足球走势| www.37gd.com-dd彩票平台真假| www.860693.com-福建体彩开奖| www.911913.com-9彩500-| www.969615.com-福利彩票谁中过大奖| www.cai5211.com甘肃快三推荐号码| www.332570.com-购买双色球彩票平台| www.ux54.com-q彩网主页-| www.08fi.com-浙江体彩大乐透规则| www.573040.com-江苏快三开奖信息| www.506610.com-竟彩网app-| www.088011.com-988彩票官网| www.wz63.cc-七星彩论坛社区| www.le47.com-彩中彩app下载| www.768728.com-uu直播手机彩| www.cai0511.com福彩快3官网app| www.ji48.com-苹果手机买彩票软件| www.976693.com-河南温县彩礼| www.us57.com-彩神争霸2官网| www.36tk.com-购彩网彩票首页| www.222290.com-体育彩票十分钟开奖| www.334306.com-彩票有少样-| www.055014.com-彩票平台出售出租| www.202628.com-福彩快乐10分开奖| www.947978.com-大乐众彩网-| 杏彩www.00840h.com| www.a36.club-彩九注册-| www.179902.com-内蒙福彩快3| www.5146.vip-福彩开奖34期| www.262263.com-快三遗漏河北| www.561037.com-彩票200期走势图| www.641177.com-600彩票网登录| www.859019.com-彩票中奖结果查询| www.931930.com-体彩门头要求| www.989677.com-即开型彩票概率分析| www.qp34.com-快三跨3号码| www.970227.com-盛邦财团彩票| www.id5.com-快三预测一定牛内蒙| www.g57.net-星彩3d论坛app| www.254973.com-彩票首次注册送彩金| www.5766.net-信博彩票平台多少钱| www.175963.com-快三开挂软件下载| www.287769.com-安卓彩票分析软件| www.71446.com-好运快三作弊| www.3ub.com-彩票走势图表2元网| www.144177.com-浙江快乐彩11| www.391267.com-意彩官网首页| www.520397.com-富人买彩票-| www.595330.com-查彩票中奖怎么查| www.708689.com-时时彩当时开奖结果| www.817252.com-江苏快三计划员| www.919814.com-福彩三d断组预测| 凤凰彩票www.77801z.com| www.677828.com-中国彩票36选七| www.801878.com-博彩奔驰宝马网址| www.915671.com-彩吧利润-| www.47fr.com-福彩南宁中奖| www.441176.com-足球竞彩qq群| www.199884.com-123彩票手机版| www.283751.com-新时时彩怎么玩|